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TRANSLATING A DOCUMENT IN TRADOS STUDIO 2017 — SHORT & SIMPLE INSTRUCTIONS

Files can be brought into Trados Studio for translation either by directly opening a file or by first
creating a project. These instructions are for the former method which is usually used when
translating a single file. For additional information, see Appendix A: Project Type Comparison.

1. Open the source file in the native application for reviewing/prepping, if needed. (This is
particularly important if the file has non-translatable content or incorrectly placed
paragraph marks.) Close the file.

2. Open the Welcome screen of Trados Studio, click the Drag files for translation or browse
your computer area and select the source file.

3. The Translate dialog box opens offering two options: Create new project OR Translate as
single document. Select Translate as single document. (Select Create new project if you
have more than one file to translate for the same project, or you want to use a specific
project template.)

4. The Translation Memory and Document Settings dialog box opens (see Figure 1). Select
Source Language and Target Language, as needed.

5. Select the translation memories (TM) you want to use from the list.

a. You can add existing TMs to the list by selecting Use... or create a new TM by selecting
Create Translation Memory.

6. Define TM usage settings (Enabled/Lookup/Penalty/Concordance/Update) for each TM, as
needed.

7. Click OK to close the Translation Memory and Document Settings dialog box. The
translation file opens in the Editor view as a bilingual SDLXLIFF file and is ready for
translation.

8. Save the bilingual SDLXLIFF file (File > Save). Pay attention to the target location! Note that
the paths on the top and the bottom part of the Save As dialog box are not necessarily the
same. Modify the File name: path, if needed!

9. Type your translation into the fourth column (second from the right).

10. While translating, utilize exact and fuzzy matches offered by the enabled TMs, AutoSuggest
suggestions (from AutoSuggest dictionaries, MultiTerm termbases, AutoText entries,
translation memories, machine translation), and the Concordance (F3) (manual search)
function. You can change the settings for most of these functions through Project Settings.
(Note that general AutoSuggest settings are located in File > Options > AutoSuggest.)

11. While translating, apply formatting and tags as needed. (See the Working with Tags topic in
the Online Help and this blog article for more information about working with tags.)



http://www.finntranslations.com/
https://docs.sdl.com/LiveContent/content/en-US/SDL%20Trados%20Studio%20Help-v4/GUID-A1AE3500-AD0E-4E17-8F52-5E3823A80B79#url=/LiveContent&addHistory=true&filename=GUID-F4116CE9-90CD-4E7F-A8F9-68260CC24147.xml&docid=GUID-C6676C93-2EEF-4945-9438-905F05EF268E
http://multifarious.filkin.com/2012/09/10/working_with_tags/

12. When a segment has been translated and formatted, confirm the translation (Ctrl+Enter or
Confirm button in the toolbar) to save it to the TM and to move to the next unconfirmed
segment (or Ctrl+Alt+Enter to confirm and move to the next segment). Note that if you
don’t confirm a segment, it does not get saved in the TM.

13. Translate the file to the end (and edit/proofread/spell-check/QA).

14. You can preview the formatted translation in the interactive Preview window (Preview tab
on the right), in the native application (File > Print & View > View In) or as a bilingual table
in a web browser (File > Print & View > Print Preview), as needed. Note that your preview
options depend on the source file type.

15. When the file has been translated and edited, save the translated target file in its original
file format (File > Save Target As). Pay attention to the target location!

16. That’s it. You have now the translated document in the original file format (in addition to
the bilingual SDLXLIFF file), and those TMs that you chose to have updated were updated
during the translation.

17. If you need to open a previously created (partially translated) bilingual SDLXLIFF file,
double-click the file name in the Files view of the project (or right click the file name and
select Open For Translation) in Trados Studio. This opens the file in the editor.

FOR MORE INFORMATION: See the Get Started and More Resources pages in the Welcome
view for accessing the Help System, Quick Start Guides, Release Notes, SDL Trados Migration
Guide, Videos and other helpful materials.
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Figure 1. Translation Memory and Document Settings dialog box with several translation
memories enabled for lookup and concordance but only one for update.
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Figure 2. Overview of the Trados Studio 2017 Editor. A file open and partially translated.
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Appendix A. Comparison of Project Types

1. Translate as single document

Only 2 questions: (1) the file and (2) the languages & translation memories

Translation Memory and Document Settings ot
Source Language: | M= English (United States) K
Target Language: || Finnish (Finland) + | (optionai)

Translation Memory and Automated Translation

Create a translation memary, select an existing translation memaory or connect to automated translation providers or other resources.
g Specify whether to include the selected providers in lookup, concordance search and whether to update them,

4 Create Translation Memary... v‘ B Use- | Remove |§. Import... B, Export... | Upgrade

Name Enabled Langusges Lookup Penalty Concordance Updat +

|§|:] Eng-Fin Kaikki Studio w2017 sdlim i v] EEa4= [v] 0 v v

Hi3 Combined Clients ver 2017 (

.sdltm v EEad= ] 2 v

H Workbench TM En-Fin ver 2017 (2).sdltm v|] EEad4= [v] 1 v
H EU Chem regulation and directives 2017 NEW.sdltm v] Es4= [/ 0 v/
+% MyMemory Plugin n/a

4 3

Dio not show this dialog again f the language pair settings for the document are known.

( Advanced. ' [ ok ][ coca |[ Hep |
Ny

The project settings of this project will be based on your default project template
settings (File > Options).

If needed, you can change TM-specific settings by selecting the Settings... button and
project-specific settings (such as File Type settings) by selecting the Advanced... button.
Does NOT include a word count analysis but it can be done separately afterwards.
Listed as "Single file project" in the Projects view.

2. Create new project

A multi-step wizard (= several questions):

0 Project Type, Project Details (name & location), Project Languages, Project Files,
TMs, Termbases, PerfectMatch, Project Preparation, Batch Processing Settings,
Project Summary

0 Can be simplified by creating and using Project Templates

Automatically includes a word count analysis.
Listed as "Studio project" in the Projects view.

3. Project package

e Contains a Studio project created by a client.
e When opened, creates a copy of the same project with its project settings on your
computer.
e You can change its client-set project settings via Project Settings, if needed.
e When translation is finished, create a Return Package to be sent to the client.
e Listed as "Studio package" in the Projects view.
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Appendix B. Options and Project Settings

The Options (File > Options) and Project Settings (Project > Project Settings...) dialog boxes
look very similar and have several identical settings. However, it’s important to understand
their difference. The Project Settings are project-specific whereas the settings in the Options
dialog box function as default settings for all future projects/files. The Project Settings override
the Options settings. So, if you want to change a setting for a current project, you need to do it
through the Project Settings dialog box if the setting is available there. Note that some settings,
such as Editor settings, are only in the Options dialog box and affect the current project as well
as all future projects. For details, see this blog article.

e Project Settings affect only your active project.

e The five “shared” items in File > Options dialog box (File Types, Embedded Content
Processors, Verification, Translation Quality Assessment and Language Pairs) affect
only future projects. These are your “global” settings for future projects. See Figure 3
below.

e The other eight items in File > Options dialog box affect active, past and future projects.
They are not really project settings but affect other, more general preferences, such as
font sizes, color, spell checker, keyboard shortcuts, etc. that control how Studio
functions, regardless of any project-specific settings.

T
Opt'lona \ Project Settings} 2-Trados Studio WS-1 practice text.doc_en-U5 i
r—————
b4 Editor, Startup w Project Name: 2712
b B AutoSuggest Autom, @ File Types
P - - Description:
/ b @ File Types Prom @ Embedded Content Processors
b [@] Embedded Content Processars Don E—} Verification
b E—}Veriﬁcation Z Translation Quality Assessment
b2 Translation Quality Assessment (== K1 Language Pairs Location: ChUsg
4 Language Pairs Auto 4-1m Al Language Pairs ] an
o ]- All Language Pairs ide-by-s b-Ef Translation Memory and Automat
b-E Translation Memory and Aut cho b E Termbases U
b- B8 Termbases < b Match Repair
o 3
3 Match Repair b--[F Batch Processing Pue Date: D 9
»-[) Batch Processing Shew b | Englisn (United States) > Fimisn Finl_Jstomer:
\ b--]® English (United States)->Finnish |
! ‘ N Formatti
3 ]- English (United Kingdom}->Finni I
V| Grou
b-[E] Default Task Sequence
b-H Translation Memories View Ena
b %) Calors [ cente
=
b-E= Keyboard Shortcuts Review
bR i
w Automatic Updates D Pro
b @ Welcome View
' Pro
AutoSavy
Enabl
AutoSa
Reset to Defaults Reset to Defaults

I

Figure B-1. Comparison of Options settings ("global settings") and Project Settings. Identical
parts are marked with a blue frame.
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Appendix C. Upgrading, Importing and Exporting Translation Memories

In addition to the normal interactive translation, Trados Studio memory content can be created
from existing translation memories and from certain bilingual files. The method used

(upgrading a TM or importing) depends on the source file and whether a new or existing Studio
TM will be used.

Translation Memory — In & Out

SDLXLIFF

(TM : Studio file
exchange | (WinAlign ( )
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(TagEditor
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Figure C-1. Functions and file types for upgrading, importing and exporting translation

memories in Trados Studio.
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Appendix D Using Termbases
Very easy to create, manage and use in Trados Studio.

e (Creating termbases

0 Create a new (empty) termbase in MultiTerm Desktop and add new terms
manually one by one.
0 |If you already have a glossary as an Excel table you can easily convert it to
MultiTerm format with the Glossary Converter app.
e Termbase activation in Studio

0 Select termbases either during project creation or afterwards from the Editor
view by selecting the Project Termbase Settings button in the Term Recognition
window. You may use several termbases at the same time.

e Termbase use during translation

0 Term Recognition is an automatic function and the results (hits) are shown in the
Term Recognition window (upper right corner by default). Term translations are
entered into translation using the AutoSuggest feature by typing the first
letter(s) of the translated term, or by using the Insert term translation button (in
the Term Recognition window).

0 Further details about the active term can be viewed by clicking the View term
details button. It opens the Termbase Viewer window on the left (by default).

e Adding new terms to the termbase

0 Select a source term and the matching target term in the Editor, right-click either

one of the terms and select Add New Term. This opens the Termbase Viewer

with the new term pair saved in the default termbase and available for editing, if
needed.
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